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1 Introduction

This book shows you how to install and setup the N108xA-Series compliance application. Once the 
procedures in this document are completed, you can begin compliance testing. Information on using 
the application is included in the application’s help system.

To Install the Application

1 Select from one of three different test-equipment configurations shown in the following pages. The 
configuration that you select depends on where the compliance applications is installed, as 
determined by the licenses, and whether you are using the N1010A FlexDCA Remote Access 
application.

2 After locating the figure that matches your setup, follow the recommended procedure.

Recommended Equipment

Table 2 on page 10 lists the recommended equipment. The equipment you select depends on the 
supported test equipment that is available to you.

NOTE Your license determines where you install the compliance and FlexDCA applications. The compliance application’s 
licenses (N1081A, N1082A, N1083A, N1084A) allows you to install the application on either a specific PC or a 
specific 86100D DCA-X instrument. This selection is made at the time that you redeem your license. 

NOTE If you plan to run all of the application’s IEEE 802.3 Ethernet KR/CR tests, you will need install each of the N1081A, 
N1082A, N1083A, and N1084A licenses. Refer to Table 1 on page 6 for a listing of the measurement options 
activated for each license.

NOTE The application cannot be installed on an 86100A, 86100B, or 86100C.
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1 Introduction

Table 1 Available Clauses Versus Installed License

IEEE 802.3
Designation

Installed License

N1081A N1082A N1083A N1084A

10GBASE-KR √ 

40GBASE-KR4 √ 

40GBASE-CR4 √ 

100GBASE-CR10 √ 

100GBASE-KR4 √ 

100GBASE-CR4 √ 

XLAUI √ 

CAUI √ 

XLPPI √ 

CPPI √ 
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Installing Both the Application and N1010A FlexDCA on a PC

If your licenses allow for installing the software as marked by the red star in this diagram, 
go to Chapter 2 on page 11.

Figure 1 N1081A-Series Application and N1010A FlexDCA Installed on PC
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1 Introduction

Installing the Application on a PC without FlexDCA

If your licenses allow for installing the software as marked by the red stars in this diagram, 
go to Chapter 3 on page 33.

Figure 2 N1081A-Series Application Installed on PC.
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Installing the Application on the 86100D

If your licenses allow for installing the software as marked by the red star in this diagram, 
go to Chapter 4 on page 55.

Figure 3 N1081A-Series Application Installed on 86100D
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1 Introduction

Recommended Equipment

Table 2 Recommended Equipment 

Equipment 86100D Module Configuration

Single Plug-In Module Setup Mul tiple Module Setup

86100D Oscilloscope 86100D DCA-X* with options:
86100D-ETR Extended Trigger
86100D-200 Enhanced Jitter Analysis
86100D-201 Advanced Waveform Analysis

86100D Plug-In Module 86108A or 86108B with options LBW/HBW and 
216/232.

N1045A, 86117A, or 86118A-H01 dual receiver.
86107A precision timebase (any option).
N4877A-216/232 (for clock recovery.†

Software N1081A, N1082A, N1083A, and N1084A IEEE 802.3 Compliance Application.

86100DU-401 Advanced Eye Software (for measuring jitter at PRBS31). 
A version of the 86100DU-401 is automatically installed with the N1081A-series application.

Keysight I/O Libraries, 16.3 or higher

Option N1010A-SIM InfiniiSim DCA Waveform Transformation Toolset.
Provides InfiniiSim Transform operators to FlexDCA.

Performance Network Analyzer 
(PNA) or Economy Network 
Analyzer (ENA)

Any 4-port model with frequency range of at least 19 GHz
(ENA also covers the 1 MHz termination mismatch test)
The network analyzer is used to perform return-loss measurements.

Switching Test Set (optional) Keysight U3020A S26 DC to 26.5 GHz, or
BitifEye BIT 2100

Matched Cable Set 86108B- CA2 or 86108B-CA3 (quantity 1)

Phase Trimmers 86108B-PT2 or 86108B-PT3 (quantity 2)

DC Blocks 86108B-DC3, N9398C, N9399C, or 11742A (quantity 2)

Pick-Off N/A N4915A-015 (quantity 2)

Test Adapters (optional) Visit http://shop.wilder-tech.com/category_s/42.htm

* FlexDCA version A.02.51 or greater

† If you have access to the clock for the device, you can connect the clock to the 86100D’s Trigger input instead of using the N4877A.
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2 Installing Both N108xA and 
N1010A FlexDCA on a PC

Follow the instructions in this chapter when you are installing both the compliance application and 
the N1010A FlexDCA application on a PC. Although a version of the 86100DU-401 software is 
automatically installed with the compliance application, you must purchase and install a license for 
the 86100DU-401.

Figure 4 N1081A-Series Application and N1010A FlexDCA Installed on PC

NOTE When you redeemed your compliance application license, you selected to install the application either on a 
specific 86100D or a specific PC.
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2 Installing Both N108xA and N1010A FlexDCA on a PC

Step 1. Connect the Equipment

1 Install one of the module combinations listed in Table 3 into the 86100D.

2 Connect the equipment as shown in Figure 4 on page 11 and turn on all of the instruments.

Step 2. Install the I/O Library Suite

1 In your internet browser, go to www.keysight.com/find/iosuite and download the Keysight 
I/O Library Suite.

2 Install the I/O Library Suite on the PC.

NOTE If you do not connect a network analyzer, you will not be able to perform the return-loss tests.

Table 3 86100D Module Solutions

Installed Module Configurations Single Plug-In 
Module Setup

Mul tiple Plug-In
Module Setup

Description

86108A/B √ The 86108B can have either options LBW 
or HBW plus 216 or 232.

N1045A, 86117A, or 86118A-H01
86107A (any option)
N4877A-216/232*

√ N4877A-216 provides a maximum data 
rate of 16 Gb/s. Option 232 provides a 
maximum data rate of 32 Gb/s.

* If you have access to the clock for the device, you can connect the clock to the 86100D’s Trigger input instead of using the N4877A.

NOTE Keysight’s I/O Library Suite is free software that automatically detects instruments connected to your PC and 
configures the interfaces. It reduces system setup and configuration time. The compliance application requires I/O 
Libraries Suite 16.3 or higher.



Installing Both N108xA and N1010A FlexDCA on a PC 2

N108xA-Series Getting Started 13

Step 3. Install the Compliance Application 

The following steps install the compliance application and its license as well as the license for the 
86100DU-401. A version of the 86100DU-401 is automatically installed for use with the compliance 
application.

1 Go to www.keysight.com and search for and download the N108xA-series application. Install the 
application on the PC for which you redeemed the license.

2 Place the license file that you received from Keysight in a folder or accessible memory device.

3 If not already done, purchase an 86100DU-401 license. Place the license file that you receive from 
Keysight in a folder or accessible memory device.

4 If the N1010A FlexDCA is running, close FlexDCA.

5 On the PC’s Windows Start menu, locate the Keysight License Manager and start it.

Figure 5 License Manager in Windows Start Menu

6 In the Keysight License Manager, select and right click the compliance application listing and click 
Install. If the compliance application is not listed, click File > Install.

7 In the Install License File(s) dialog box, locate your license file and click Open. You may have up four 
licenses: N1081A, N1082A, N1083A, and N1084A as shown in Figure 6 on page 14.

NOTE When you redeemed a compliance application license, you selected to install the application either on a specific 
86100D or a specific PC.

NOTE If you are using one of the switching test sets (switch matrix), you will also need one of the N1081A-7FP, 
N1082A-7FP, N1083A-7FP, or N1084A-7FP licenses.
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Figure 6 N1081A-Series Application Licenses in Keysight License Manager

8 Select and install the 86100DU-401 license.

9 Close the Keysight License Manager.

NOTE If you plan to run all of the application’s IEEE 802.3 Ethernet KR/CR tests, you will need install one each of the 
N1081A, N1082A, N1083A, and N1084A licenses.
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Step 4. Connect N1010A FlexDCA to the 86100D

1 On the 86100D, click Help > About and locate the System Information field in the dialog box. Scroll the 
field to view the Computer Name entry. You can also obtain the computer name from the Windows 
System properties.

2 Record the Computer Name (host name) as you will need this name later in this procedure.

86100D Computer Name: ________________________

3 Close the About dialog box.

4 Do the following steps to place the 86100D in Legacy configuration:

a Click File > Exit on the 86100D’s user interface.
b On the Windows Start menu, click All Programs > Keysight FlexDCA > Legacy UI.

Figure 7 86100D User Interfaces

5 On the PC, start the N1010A FlexDCA application.

6 When FlexDCA starts, if the Extended Module Configuration dialog box is displayed, click Setup. If the 
dialog box does not open, click Setup > DCA Connection Setup.

7 In the FlexDCA Connection Setup dialog box, select Connect Using LAN as shown in Figure 8.
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2 Installing Both N108xA and N1010A FlexDCA on a PC

Figure 8 Example of N1010A FlexDCA Connection Setup

8 Enter the 86100D’s Hostname that you recorded in step 2.

9 Click Connect in the dialog box.

10 Minimize the N1010A FlexDCA application.
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Step 5. Add ENA Network Analyzer to Keysight Connection 
Expert

An ENA or PNA network analyzer is required to perform the return-loss measurements.

1 Locate the ENA instrument’s Hostname (Full Computer Name) and record it on the following line. 
Refer to the network analyzer‘s documentation for locating this information.

Hostname: __________________________

2 On the PC’s Windows Start menu, click Keysight IO Libraries Suite > Keysight Connection Expert and wait 
for the Keysight Connection Expert to open.

Figure 9 Starting Connection Expert in Windows Start Menu

3 In Keysight Connection Expert, click the LAN I/O interface identified in Figure 10. Then, click Add 
Instrument.

NOTE If you are using a PNA instead of an ENA network analyzer, skip these steps and continue with “Step 6. Add PNA 
Network Analyzer to Keysight Connection Expert" on page 20.

NOTE A connection is established to an ENA using the LAN protocol.
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2 Installing Both N108xA and N1010A FlexDCA on a PC

Figure 10 Adding FlexDCA

4 In the Add LAN Instruments dialog box, click the Add Address button to add the network analyzer.

5 In the Enter Instrument Address field, enter the Hostname of the network analyzer that you recorded 
above. Figure 11 on page 19 shows an example of this dialog box with the proper settings.

6 In the Optional Connection Information field, select Defaul t instrument.

7 In the Instrument identification field, select *IDN query.

8 To confirm your settings, click the Test Connection and Identify Instrument buttons.

9 Click OK to close the dialog box.
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Figure 11 Connection Settings for ENA Network Analyzer (Your Hostname entry will be different!)

10 Continue with “Step 7. Add N4877A to Keysight Connection Expert" on page 22.



20  N108xA-Series Getting Started

2 Installing Both N108xA and N1010A FlexDCA on a PC

Step 6. Add PNA Network Analyzer to Keysight Connection 
Expert

1 If you already connected an ENA network analyzer, skip these steps and continue with “Step 7. Add 
N4877A to Keysight Connection Expert" on page 22.

2 Locate the PNA instrument’s IP address and record it on the following line. Refer to the network 
analyzer‘s documentation for locating this information.

IP Address: ___________________________________

3 On the PC’s Windows Start menu, click Keysight IO Libraries Suite > Keysight Connection Expert and wait 
for the Keysight Connection Expert to open.

4 In Keysight Connection Expert, click the LAN I/O interface identified in Figure 12. Then, click Add 
Instrument.

NOTE A connection is established to a PNA using the sockets protocol.
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Figure 12 Adding FlexDCA

5 In the Add LAN Instruments dialog box, click the Add Address button to add the network analyzer.

6 In the Enter Instrument Address field, enter the IP address of the network analyzer that you recorded 
above. Figure 13 on page 21 shows an example of this dialog box with the proper settings.

7 In the Optional Connection Information field, select Socket.

8 In the Instrument identification field, select *IDN query.

9 To confirm your settings, click the Test Connection and Identify Instrument buttons.

10 Click OK to close the dialog box.

Figure 13 Connection Settings for PNA Network Analyzer (Your IP Address entry will be different!)
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2 Installing Both N108xA and N1010A FlexDCA on a PC

Step 7. Add N4877A to Keysight Connection Expert

The N4877A is required in dual-module test setups. If you are using an 86108A/B module, skip this 
step.

If the N4877A is connected in your test setup via USB, Keysight Connection Expert should 
automatically detect the connection. If the N4877A is connected using the LAN, add it to Keysight 
Connection Expert.

Figure 14 Example N4877A USB Connection Shown in Keysight Connection Expert
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Step 8 (Optional). Add Switching Test Set to Keysight 
Connection Expert

The compliance application supports Keysight’s U3020A S26 switching test set and the BitifEye BIT 
2100. The following steps illustrate connecting to an Keysight U3020A S26.

1 Locate the switching test set’s IP address and record it on the following line. Refer to the instrument’s 
documentation for locating this information.

IP Address: _________________

2 Open the Keysight Connection Expert.

3 In Keysight Connection Expert, right click on the LAN I/O interface identified in Figure 15. Then, click 
Add Instrument.

Figure 15 Adding the Switching Test Set

4 In the Add LAN Instruments dialog box, use the Auto Find feature to locate and select the switching 
test set. Click OK to close the dialog box.

5 The connection to the switching test set should now be shown in Keysight Connection Expert as 
shown in Figure 16.

NOTE To use a switching test set (switch matrix), you must first install one of the N1081A-7FP, N1082A-7FP, N1083A-7FP, 
or N1084A-7FP application licenses.
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Figure 16 Connection Established for Switching Test Set, Network Analyzer, and Optional N4877A
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Step 9. Start the Compliance Application

1 Minimize the Keysight Connection Expert if it is open.

2 On N1010A FlexDCA, click Apps > Automated Test Apps > N108xA IEEE802.3 Test App.

Figure 17 Starting the Compliance Application From the 86100D Menu

3 If a dialog box appears, click OK to close it.
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Step 10. Connect to the ENA Network Analyzer

1 In the compliance application’s Set Up tab, select ENA for the network analyzer and then click 
Connect PNA/ENA.

Figure 18 Selecting an ENA Network Analyzer

2 Go to the Keysight Connection Expert, right click on the ENA listing, and copy the SICL address that 
is shown in Figure 19.

Figure 19 Copy ENA’s SICL Address

3 Return to the compliance application.

NOTE If you are using a PNA instead of an ENA network analyzer, skip these steps and continue with “Step 11. Connect 
to the PNA Network Analyzer" on page 28.
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4 Select Enter full SICL address and paste (CTRL-V) the SICL address into the field as shown in Figure 20.

5 Click Identify to confirm the connection.

6 Click OK to close the dialog box.

Figure 20 SICL Address Pasted into Dialog Box

7 Continue with “Step 12. Connect to the N4877A" on page 30.
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Step 11. Connect to the PNA Network Analyzer

1 In the compliance application’s Set Up tab, select PNA for the network analyzer and then click 
Connect PNA/ENA.

Figure 21 Selecting an PNA Network Analyzer

2 Go to the Keysight Connection Expert, right click on the PNA listing, and copy the SICL address that 
is shown in Figure 19.

Figure 22 Copy PNA’s SICL Address

NOTE If you are using an ENA instead of an PNA network analyzer, skip these steps and continue with “Step 12. 
Connect to the N4877A" on page 30.

NOTE Notice that this LAN address for the PNA has the form lan,5025[IP address].
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3 Return to the compliance application:

4 Select Enter full SICL address or VISA alias and paste (CTRL-V) the SICL address into the field as shown in 
Figure 23.

5 Click Identify to confirm the connection.

6 Click OK to close the dialog box.

Figure 23 SICL Address Pasted into Dialog Box
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Step 12. Connect to the N4877A

1 In the compliance application’s Set Up tab, click the Connect N4877A button that is located at the 
bottom of the window.

2 Enter the full SICL address or VISA alias. Or, select Select from Keysight Connection Expert as shown in 
Figure 24.

3 Click Identify to confirm the connection.

Figure 24 N4877A Selected from Connection Expert

4 Click OK to close the dialog box.

NOTE Skip this step if your test setup uses an 86108A/B module. The N4877A Clock Data Recovery & Demultiplexer is 
used whenever two 86100D modules are used in the test setup rather than an 86108A/B module. Refer to Table 3 
on page 12.
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Step 13 (Optional). Connect to a Switching Test Set

1 Go to the Keysight Connection Expert, click on the switching test set listing as shown in Figure 25.

2 Right click the SICL address and select copy.

Figure 25 Copy Switching Test Set’s SICL Address

3 Return to the compliance application:

4 In the compliance application’s Set Up tab, click the Switch Matrix Setup button that is located at the 
bottom of the window.

5 In the Configure Switch Matrix Settings dialog box, select On which is located at the top of the dialog box 
as shown in Figure 26 on page 32.

6 In the dialog box’s Controller tab, select Automatically select drivers and paths (l imited models).

7 In the Switch Drivers field, click the Models drop-down list to select Keysight U3020A S26.

8 Click on the blank entry line shown in Figure 26.

9 Click Connect to open the Connect to Keysight U3020A S26 dialog box.

NOTE This section shows how to connect the optional Keysight U3020A S26 Switching Test Set. Connecting a BitifEye BIT 
2100 would be similar.

NOTE This button is only displayed if Switch Matrix is selected for the Multi-Lane Test Option field.
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Figure 26 Configure Tab Settings

10 In the dialog box, select Enter full SICL address or VISA alias and paste (CTRL-V) the SICL address into 
the field as shown in Figure 27.

11 Click Identify to confirm the connection.

12 Click OK to close the dialog box.

Figure 27 Entering the Switching Test Set’s Address

13 Refer to the compliance application’s Help system to learn how to configure the switch settings.
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3 Installing N108xA on a PC 
Without N1010A FlexDCA

Follow the instructions in this chapter when you are installing the compliance application on a PC, 
but you are not installing the N1010A FlexDCA application. Although a version of the 86100DU-401 
software is automatically installed with the N1081A-series application, you must purchase and install 
a license for the 86100DU-401.

Figure 28 Compliance Application Installed on PC Without N1010A FlexDCA

NOTE If you do not connect a network analyzer, you will not be able to perform the return-loss tests.
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3 Installing N108xA on a PC Without N1010A FlexDCA

Step 1. Connect the Equipment

1 Install one of the module combinations listed in Table 4 into the 86100D.

2 Connect the equipment as shown in Figure 28 on page 33 and turn on all of the instruments.

Step 2. Place the 86100D in Standard Configuration

1 Start the 86100D.

2 If the 86100D’s Legacy GUI is visible, click File > Exit to exit the GUI and view the Windows desktop.

Figure 29 86100D User Interfaces

3 On the Windows Start menu, click All Programs > Keysight FlexDCA > Keysight FlexDCA.

Table 4 86100D Module Solutions

Installed Module Configurations Single Plug-In 
Module Setup

Mul tiple Plug-In
Module Setup

Description

86108A/B √ The 86108B can have either options LBW 
or HBW plus 216 or 232.

N1045A, 86117A, or 86118A-H01
86107A (any option)
N4877A-216/232 *

√ N4877A-216 provides a maximum data 
rate of 16 Gb/s. Option 232 provides a 
maximum data rate of 32 Gb/s.

* If you have access to the clock for the device, you can connect the clock to the 86100D’s Trigger input instead of using the N4877A.
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Step 3. Install the I/O Library Suite

1 In your internet browser, go to www.keysight.com/find/iosuite and download the Keysight 
I/O Library Suite.

2 Install the I/O Library Suite on the same PC where you will install the compliance application.

Step 4. Install the Compliance Application 

The following steps install the compliance application and its license as well as the license for the 
86100DU-401. A version of the 86100DU-401 is automatically installed for use with the compliance 
application.

1 Go to www.keysight.com and search for and download the compliance application. Install the 
application on the specific PC for which you redeemed the license.

2 Place the license file that you received from Keysight in a folder or accessible memory device.

3 If not already done so, purchase an 86100DU-401 license. Place the license file that you received 
from Keysight in a folder or accessible memory device.

4 On the PC’s Windows start menu, locate the Keysight License Manager and start it.

Figure 30 License Manager in Windows Start Menu

NOTE Keysight’s I/O Library Suite is free software that automatically detects instruments connected to your PC and 
configures the interfaces. It reduces system setup and configuration time. The compliance application requires 
Keysight I/O Libraries Suite 16.3 or higher.

NOTE When you redeemed a compliance application license, you selected to install the application either on a specific 
86100D or a specific PC.
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5 In the Keysight License Manager, select and right click the compliance application listing and click 
Install. If the compliance application is not listed, click File > Install.

6 In the Install License File(s) dialog box, locate your license file and click Open. You may have up four 
licenses: N1081A, N1082A, N1083A, and N1084A as shown in Figure 31 on page 36.

Figure 31 Compliance Application Licenses in Keysight License Manager

7 Select and install the 86100DU-401 license on the 86100D.

8 Close the Keysight License Manager.

NOTE If you are using one of the switching test sets (switch matrix), you will also need one of the N1081A-7FP, 
N1082A-7FP, N1083A-7FP, or N1084A-7FP licenses.

NOTE If you plan to run all of the application’s IEEE 802.3 Ethernet KR/CR tests, you will need install one each of the 
N1081A, N1082A, N1083A, and N1084A licenses.
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Step 5. Configure 86100D’s SCPI Server Setup

1 On the 86100D, click Help > About and locate the System Information field in the dialog box. Scroll the 
field to view the Computer Name entry. You can also obtain the computer name from the Windows 
System properties.

2 Record the Computer Name (host name) as you will need this name later in this procedure.

86100D Computer Name: ________________________

3 Close the dialog box.

4 Click Tools > SCPI Programming Tools > SCPI Server Setup.

5 In the dialog box, confirm that the Sockets and HiSLIP interfaces are selected (Enabled) as shown in 
Figure 32.

6 Close the dialog box.

Figure 32 86100D’s SCPI Server Setup Dialog Box
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Step 6. Add 86100D to Keysight Connection Expert

1 On the PC’s Windows Start menu, click Keysight IO Libraries Suite > Keysight Connection Expert and wait 
for the Keysight Connection Expert to open.

Figure 33 Starting Connection Expert in Windows Start Menu

2 In Keysight Connection Expert, click the LAN interface identified in Figure 34. Then, click Add 
Instrument on the toolbar.

Figure 34 Adding FlexDCA
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3 In the Add LAN Instruments dialog box, click the Add Address button to add the 86100D.

4 In the Enter Instrument Address field, select Use Hostname and enter the 86100D’s computer name 
that you recorded in step 2 on page 37. Figure 35 shows an example of this dialog box with the 
settings configured.

5 In the Optional Connection Information field, select HiSLIP. The Device Name should be listed as hisl ip0. 
FlexDCA uses the HiSLIP protocol.

6 In the Instrument identification field, select *IDN query.

7 To confirm your settings, click the Test Connection and Identify Instrument buttons.

8 Click OK to close the dialog box.

Figure 35 Add LAN Instrument Settings (Your Hostname entry will be different!)

9 The 86100D (HSLIP protocol) connection is now listed as shown in Figure 36 on page 40.
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Figure 36 86100D (HSLIP protocol) Connection
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Step 7. Add ENA Network Analyzer to Keysight Connection 
Expert

An ENA or PNA network analyzer is required to perform the return-loss measurements.

1 Locate the ENA instrument’s Hostname (Full Computer Name) and record it on the following line. 
Refer to the network analyzer‘s documentation for locating this information.

Hostname: ___________________

2 On the PC, view the Keysight Connection Expert, and click the LAN I/O interface identified in 
Figure 37. Then, click Add Instrument.

Figure 37 Adding the ENA

3 In the Add LAN Instruments dialog box, click the Add Address button to add the network analyzer.

4 In the Enter Instrument Address field, enter the Hostname of the network analyzer that you recorded 
above. Figure 38 on page 42 shows an example of this dialog box with the proper settings.

5 In the Optional Connection Information field, select Defaul t instrument.

NOTE If you are using a PNA instead of an ENA network analyzer, skip these steps and continue with “Step 8. Add PNA 
Network Analyzer to Keysight Connection Expert" on page 43.

NOTE A connection is established to an ENA using the LAN protocol.
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6 In the Instrument identification field, select *IDN query.

7 To confirm your settings, click the Test Connection and Identify Instrument buttons.

8 Click OK to close the dialog box.

Figure 38 Connection Settings for ENA Network Analyzer (Your Hostname entry will be different!)

9 Continue with “Step 9. Add N4877A to Keysight Connection Expert" on page 45.
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Step 8. Add PNA Network Analyzer to Keysight Connection 
Expert

1 If you already connected an ENA network analyzer, skip these steps and continue with “Step 9. Add 
N4877A to Keysight Connection Expert" on page 45.

2 Locate the PNA instrument’s IP address and record it on the following line. Refer to the network 
analyzer‘s documentation for locating this information.

IP Address:

3 On the PC, view the Keysight Connection Expert, and click the LAN I/O interface identified in 
Figure 39. Then, click Add Instrument.

Figure 39 Adding the PNA

4 In the Add LAN Instruments dialog box, click the Add Address button to add the network analyzer.

5 In the Enter Instrument Address field, enter the IP address of the network analyzer that you recorded 
above. Figure 40 on page 44 shows an example of this dialog box with the proper settings.

6 In the Optional Connection Information field, select Socket.

7 In the Instrument identification field, select *IDN query.

8 To confirm your settings, click the Test Connection and Identify Instrument buttons.

9 Click OK to close the dialog box.

NOTE A connection is established to a PNA using the sockets protocol.
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Figure 40 Connection Settings for PNA Network Analyzer (Your IP Address entry will be different!)
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Step 9. Add N4877A to Keysight Connection Expert

The N4877A is required in dual-module test setups. If you are using an 86108A/B module, skip this 
step.

If the N4877A is connected in your test setup via USB, Keysight Connection Expert should 
automatically detect the connection. If the N4877A is connected using the LAN, add it to Keysight 
Connection Expert.

Figure 41 Example Connections Shown in Keysight Connection Expert
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Step 10 (Optional). Add Switching Test Set to Keysight 
Connection Expert

The compliance application supports Keysight’s U3020A S26 switching test set and the BitifEye BIT 
2100. The following steps illustrate connecting to an Keysight U3020A S26.

1 Locate the switching test set’s IP address and record it on the following line. Refer to the instrument’s 
documentation for locating this information.

IP Address: ___________________

2 Open the Keysight Connection Expert.

3 In Keysight Connection Expert, right click on the LAN I/O interface identified in Figure 42. Then, click 
Add Instrument.

Figure 42 Adding FlexDCA

4 In the Add LAN Instruments dialog box, use the Auto Find feature to locate and select the switching 
test set. Click OK to close the dialog box.

5 The connection to the switching test set should now be shown in Keysight Connection Expert as 
shown in Figure 43.

NOTE To use a switching test set (switch matrix), you must first install one of the N1081A-7FP, N1082A-7FP, N1083A-7FP, 
or N1084A-7FP application licenses.
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Figure 43 Connection Established for Switching Test Set, Network Analyzer, and Optional N4877A



48  N108xA-Series Getting Started

3 Installing N108xA on a PC Without N1010A FlexDCA

Step 11. Start the Compliance Application

1 Minimize the Keysight Connection Expert if it is open.

2 On the PC’s start menu, click Launch User Defined Application 'N108xA IEEE802.3 Test App’.

3 The Connect to Scope dialog box will open as shown in Figure 44.

4 Select Select from Keysight Connection Expert as shown in the figure.

5 Select Identify/Remove inactive instruments.

6 Click the 86100D’s listing (with the host name in the SICL Address field) and then click OK to close 
the dialog box.

Figure 44 Connect to Scope Dialog Box

7 If a dialog box appears, click OK to close it.
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Step 12. Connect to the ENA Network Analyzer

1 In the compliance application’s Set Up tab, select ENA for the network analyzer and then click 
Connect PNA/ENA.

Figure 45 Selecting an ENA Network Analyzer

2 Go to the Keysight Connection Expert, click on the ENA listing, and copy (CTRL-C) the SICL address 
that is shown in Figure 46.

Figure 46 Copy ENA’s SICL Address

3 Return to the compliance application.

4 Select Enter full SICL address and paste (CTRL-V) the SICL address into the field as shown in Figure 47 
on page 50.

5 Click Identify to confirm the connection.

NOTE If you are using a PNA instead of an ENA network analyzer, skip these steps and continue with “Step 13. Connect 
to the PNA Network Analyzer" on page 51.
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6 Click OK to close the dialog box.

Figure 47 SICL Address Pasted into Dialog Box

7 Continue with “Step 14. Connect to the N4877A" on page 52.
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Step 13. Connect to the PNA Network Analyzer

1 Go to the Keysight Connection Expert, click on the PNA listing, and copy (CTRL-C) the SICL address 
that is shown in Figure 48.

Figure 48 Copy PNA’s SICL Address

2 Return to the compliance application.

3 Select Enter full SICL address or VISA alias and paste (CTRL-V) the SICL address into the field as shown in 
Figure 49.

4 Click Identify to confirm the connection. Click OK to close the dialog box.

NOTE If you already connected an ENA network analyzer, skip these steps and continue with “Step 14. Connect to the 
N4877A" on page 52.

NOTE Notice that this LAN address for the PNA has the form lan,5025[IP address].
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Figure 49 SICL Address Pasted into Dialog Box

Step 14. Connect to the N4877A

1 In the compliance application’s Set Up tab, click the Connect N4877A button that is located at the 
bottom of the window.

2 Enter the full SICL address or VISA alias. Or, select Select from Keysight Connection Expert as shown in 
Figure 50.

3 Click Identify to confirm the connection.

Figure 50 N4877A Selected from Connection Expert

4 Click OK to close the dialog box.

NOTE Skip this step if your test setup uses an 86108A/B module. The N4877A Clock Data Recovery & Demultiplexer is 
used whenever two 86100D modules are used in the test setup rather than an 86108A/B module. Refer to Table 4 
on page 34.
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Step 15 (Optional). Connect to Switching Test Set

1 Go to the Keysight Connection Expert, click on the switching test set listing as shown in Figure 51.

2 Right click the SICL address and select copy.

Figure 51 Copy Switching Test Set’s SICL Address

3 Return to the compliance application:

4 In the compliance application’s Set Up tab, click the Switch Matrix Setup button that is located at the 
bottom of the window.

5 In the Configure Switch Matrix Settings dialog box, select On which is located at the top of the dialog box 
as shown in Figure 52.

6 In the dialog box’s Controller tab, select Automatically select drivers and paths (l imited models).

7 In the Switch Drivers field, click the Models drop-down list to select Keysight U3020A S26.

8 Click on the blank entry line shown in Figure 52.

9 Click Connect to open the Connect to Keysight U3020A S26 dialog box.

NOTE This section shows how to connect the optional Keysight U3020A S26 Switching Test Set. Connecting a BitifEye BIT 
2100 would be similar.

NOTE This button is only displayed if Switch Matrix is selected for the Multi-Lane Test Option field.
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Figure 52 Configure Tab Settings

10 In the dialog box, select Enter full SICL address or VISA alias and paste (CTRL-V) the SICL address into 
the field as shown in Figure 53.

11 Click Identify to confirm the connection.

12 Click OK to close the dialog box.

Figure 53 Entering the Switching Test Set’s Address

13 Refer to the application’s Help system to learn how to configure the switch settings.
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4 Installing N108xA on the 
86100D

Follow the instructions in this chapter when you are installing both the compliance application and 
the FlexDCA application on the 86100D. Although a version of the 86100DU-401 software is 
automatically installed with the compliance application, you must purchase and install a license for 
the 86100DU-401.

Figure 54 Compliance Application Installed on 86100D

NOTE If you do not connect a network analyzer, you will not be able to perform the return-loss tests.
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Step 1. Connect the Equipment

1 Install one of the module combinations listed in Table 5 into the 86100D.

2 Connect the equipment as shown in Figure 54 on page 55 and turn on all of the instruments.

Step 2. Place the 86100D in Standard Configuration

1 Start the 86100D.

2 If the 86100D’s Legacy GUI is visible, click File > Exit to exit the GUI and view the Windows desktop.

Figure 55 86100D User Interfaces

3 On the Windows Start menu, click All Programs > Keysight FlexDCA > Keysight FlexDCA.

4 Minimize the 86100D’s graphical user interface so that you can see the Windows desktop.

Table 5 86100D Module Solutions

Installed Module Configurations Single Plug-In 
Module Setup

Mul tiple Plug-In
Module Setup

Description

86108A/B √ The 86108B can have either options LBW 
or HBW plus 216 or 232.

N1045A, 86117A, or 86118A-H01
86107A (any option)
N4877A-216/232*

√ N4877A-216 provides a maximum data 
rate of 16 Gb/s. Option 232 provides a 
maximum data rate of 32 Gb/s.

* If you have access to the clock for the device, you can connect the clock to the 86100D’s Trigger input instead of using the N4877A.
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Step 3. Install the I/O Library Suite

1 In your internet browser, go to www.keysight.com/find/iosuite and download the Keysight 
I/O Library Suite.

2 Install the I/O Library Suite on the same 86100D where you will install the compliance application.

NOTE Keysight’s I/O Library Suite is free software that automatically detects instruments connected to your PC and 
configures the interfaces. It reduces system setup and configuration time. The compliance application requires 
Keysight I/O Libraries Suite 16.3 or higher.
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Step 4. Install the Compliance Application 

The following steps install the compliance application and its license as well as the license for the 
86100DU-401. A version of the 86100DU-401 is automatically installed for use with the compliance 
application.

1 Go to www.keysight.com and search for and download the compliance application. Install the 
application on the specific 86100D for which you redeemed the license.

2 Place the license file that you received from Keysight in a folder or accessible memory device.

3 If not already done, purchase an 86100DU-401 license. Place the license file that you received from 
Keysight in a folder or accessible memory device.

4 On the Windows start menu, locate the Keysight License Manager and start it.

Figure 56 License Manager in Windows Start Menu

5 In the Keysight License Manager, select and right click the compliance application listing and click 
Install. If the compliance application is not listed, click File > Install.

6 In the Install License File(s) dialog box, locate your license file and click Open. You may have up four 
licenses: N1081A, N1082A, N1083A, and N1084A as shown in Figure 57 on page 59.

NOTE When you redeemed a compliance application license, you selected to install the application either on a specific 
86100D or a specific PC.

NOTE If you are using one of the switching test sets (switch matrix), you will also need one of the N1081A-7FP, 
N1082A-7FP, N1083A-7FP, or N1084A-7FP licenses.
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Figure 57 N1081A-Series Application Licenses in Keysight License Manager

7 Select and install the 86100DU-401 license.

8 Close the Keysight License Manager.

NOTE If you plan to run all of the application’s IEEE 802.3 Ethernet KR/CR tests, you will need install one each of the 
N1081A, N1082A, N1083A, and N1084A licenses.
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Step 5. Configure 86100D’s SCPI Server Setup

1 On the 86100D, click Help > About and locate the System Information field in the dialog box. Scroll the 
field to view the Computer Name entry. You can also obtain the computer name from the Windows 
System properties.

2 Record the Computer Name (host name) as you will need this name later in this procedure.

86100D Computer Name: ________________________

3 Close the dialog box.

4 click Tools > SCPI Programming Tools > SCPI Server Setup to open the dialog box.

5 Confirm that the Sockets and HiSLIP interfaces are selected (Enabled) as shown in Figure 58.

6 Close the dialog box.

Figure 58 FlexDCA’s SCPI Server Setup Dialog Box

7 Minimize the FlexDCA application and the 86100D application so that you can view the Windows 
desktop.
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Step 6. Add 86100D to Keysight Connection Expert

1 On the PC’s Windows Start menu, click Keysight IO Libraries Suite > Keysight Connection Expert and wait 
for the Keysight Connection Expert to open.

Figure 59 Starting Connection Expert in Windows Start Menu

2 In Keysight Connection Expert, click the LAN interface identified in Figure 60. Then, click Add 
Instrument on the toolbar.

Figure 60 Adding 86100D
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3 In the Add LAN Instruments dialog box, click the Add Address button to add the 86100D.

4 In the Enter Instrument Address field, select Use Hostname and enter the 86100D’s computer name 
that you recorded in step 2 on page 60. Figure 61 shows an example of this dialog box with the 
settings configured.

5 In the Optional Connection Information field, select HiSLIP. The Device Name should be listed as hisl ip0. 
FlexDCA uses the HiSLIP protocol.

6 In the Instrument identification field, select *IDN query.

7 To confirm your settings, click the Test Connection and Identify Instrument buttons.

8 Click OK to close the dialog box.

Figure 61 Add LAN Instrument Settings (Your Hostname entry will be different!)

9 The 86100D (HSLIP protocol) connection is now listed as shown in Figure 62 on page 63.
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Figure 62 86100D (HSLIP protocol) Connection
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Step 7. Add ENA Network Analyzer to Keysight Connection 
Expert

An ENA or PNA network analyzer is required to perform the return loss tests.

1 Locate the ENA instrument’s Hostname (Full Computer Name) and record it on the following line. 
Refer to the network analyzer‘s documentation for locating this information.

Hostname: ___________________

2 On the PC, view the Keysight Connection Expert, and click the LAN I/O interface identified in 
Figure 63. Then, click Add Instrument.

Figure 63 Adding the ENA

3 In the Add LAN Instruments dialog box, click the Add Address button to add the network analyzer.

4 In the Enter Instrument Address field, enter the Hostname of the network analyzer that you recorded 
above. Figure 64 on page 65 shows an example of this dialog box with the proper settings.

5 In the Optional Connection Information field, select Defaul t instrument.

NOTE If you are using a PNA instead of an ENA network analyzer, skip these steps and continue with “Step 8. Add PNA 
Network Analyzer to Keysight Connection Expert" on page 66.

NOTE A connection is established to an ENA using the LAN protocol.
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6 In the Instrument identification field, select *IDN query.

7 To confirm your settings, click the Test Connection and Identify Instrument buttons.

8 Click OK to close the dialog box.

Figure 64 Connection Settings for ENA Network Analyzer (Your Hostname entry will be different!)

9 Continue with “Step 9. Add N4877A to Keysight Connection Expert" on page 68.
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Step 8. Add PNA Network Analyzer to Keysight Connection 
Expert

1 If you already connected an ENA network analyzer, skip these steps and continue with “Step 9. Add 
N4877A to Keysight Connection Expert" on page 68.

2 Locate the PNA instrument’s IP address and record it on the following line. Refer to the network 
analyzer‘s documentation for locating this information.

IP Address: ______________________

3 On the PC, view the Keysight Connection Expert, and click the LAN I/O interface identified in 
Figure 65. Then, click Add Instrument.

Figure 65 Adding the PNA

4 In the Add LAN Instruments dialog box, click the Add Address button to add the network analyzer.

5 In the Enter Instrument Address field, enter the IP address of the network analyzer that you recorded 
above. Figure 66 on page 67 shows an example of this dialog box with the proper settings.

6 In the Optional Connection Information field, select Socket.

7 In the Instrument identification field, select *IDN query.

8 To confirm your settings, click the Test Connection and Identify Instrument buttons.

9 Click OK to close the dialog box.

NOTE A connection is established to a PNA using the sockets protocol.
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Figure 66 Connection Settings for PNA Network Analyzer (Your IP Address entry will be different!)
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Step 9. Add N4877A to Keysight Connection Expert

The N4877A is required in dual-module test setups. If you are using an 86108A/B module, skip this 
step.

If the N4877A is connected in your test setup via USB, Keysight Connection Expert should 
automatically detect the connection. If the N4877A is connected using the LAN, add it to Keysight 
Connection Expert.

Figure 67 Example Keysight Connection Expert Connections
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Step 10 (Optional). Add Switching Test Set to Keysight 
Connection Expert

The compliance application supports Keysight’s U3020A S26 switching test set and the BitifEye BIT 
2100. The following steps illustrate connecting to an Keysight U3020A S26.

1 Locate the switching test set’s IP address and record it on the following line. Refer to the instrument’s 
documentation for locating this information.

IP Address: _________________________

2 Open the Keysight Connection Expert.

3 In Keysight Connection Expert, right click on the LAN I/O interface identified in Figure 68. Then, click 
Add Instrument.

Figure 68 Adding FlexDCA

4 In the Add LAN Instruments dialog box, use the Auto Find feature to locate and select the switching 
test set. Click OK to close the dialog box.

5 The connection to the switching test set should now be shown in Keysight Connection Expert as 
shown in Figure 69.

NOTE To use a switching test set (switch matrix), you must first install one of the N1081A-7FP, N1082A-7FP, N1083A-7FP, 
or N1084A-7FP application licenses.
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Figure 69 Connection Established for Switching Test Set, Network Analyzer, and Optional N4877A
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Step 11. Start the Compliance Application

1 Click Apps > Automated Test Apps > N108xA IEEE802.3 Test App.

2 If a dialog box appears, click OK to close it.

Figure 70 Starting the N1081A-Series Application From the 86100D Menu

Step 12. Connect to the ENA Network Analyzer

1 In the compliance application’s Set Up tab, select ENA for the network analyzer and then click 
Connect PNA/ENA.

Figure 71 Selecting an ENA Network Analyzer

NOTE If you are using a PNA instead of an ENA network analyzer, skip these steps and continue with “Step 13. Connect 
to the PNA Network Analyzer" on page 73.
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2 Go to the Keysight Connection Expert, click on the ENA listing, and copy (CTRL-C) the SICL address 
that is shown in Figure 72.

Figure 72 Copy ENA’s SICL Address

3 Return to the compliance application.

4 Select Enter full SICL address and paste (CTRL-V) the SICL address into the field as shown in Figure 73.

5 Click Identify to confirm the connection.

6 Click OK to close the dialog box.

Figure 73 SICL Address Pasted into Dialog Box

7 Continue with “Step 14. Connect to the N4877A" on page 75.
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Step 13. Connect to the PNA Network Analyzer

1 In the compliance application’s Set Up tab, select PNA for the network analyzer and then click 
Connect PNA/ENA.

Figure 74 Selecting an PNA Network Analyzer

2 Go to the Keysight Connection Expert, click on the PNA listing, and copy (CTRL-C) the SICL address 
that is shown in Figure 75.

Notice that this LAN address for the PNA has the form lan,5025[IP address].

Figure 75 Copy PNA’s SICL Address

3 Return to the compliance application.

4 Select Enter full SICL address or VISA alias and paste (CTRL-V) the SICL address into the field as shown in 
Figure 76.

5 Click Identify to confirm the connection.

6 Click OK to close the dialog box.

NOTE If you already connected an ENA network analyzer, skip these steps and continue with “Step 14. Connect to the 
N4877A" on page 75.
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Figure 76 SICL Address Pasted into Dialog Box
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Step 14. Connect to the N4877A

1 In the compliance application’s Set Up tab, click the Connect N4877A button that is located at the 
bottom of the window.

2 Enter the full SICL address or VISA alias. Or, select Select from Keysight Connection Expert as shown in 
Figure 77.

3 Click Identify to confirm the connection.

Figure 77 N4877A Selected from Connection Expert

4 Click OK to close the dialog box.

NOTE Skip this step if your test setup uses an 86108A/B module. The N4877A Clock Data Recovery & Demultiplexer is 
used whenever two 86100D modules are used in the test setup rather than an 86108A/B module. Refer to Table 5 
on page 56.
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Step 15. Connect to the Optional Switching Test Set

1 Go to the Keysight Connection Expert, click on the switching test set listing as shown in Figure 78.

2 Right click the SICL address and select copy.

Figure 78 Copy Switching Test Set’s SICL Address

3 Return to the compliance application.

4 In the compliance application’s Set Up tab, click the Switch Matrix Setup button that is located at the 
bottom of the window.

5 In the Configure Switch Matrix Settings dialog box, select On which is located at the top of the dialog box 
as shown in Figure 79.

6 In the dialog box’s Controller tab, select Automatically select drivers and paths (l imited models).

7 In the Switch Drivers field, click the Models drop-down list to select Keysight U3020A S26.

8 Click on the blank entry line shown in Figure 79.

9 Click Connect to open the Connect to Keysight U3020A S26 dialog box.

NOTE This section shows how to connect the optional Keysight U3020A S26 Switching Test Set. Connecting a BitifEye BIT 
2100 would be similar.

NOTE This button is only displayed if Switch Matrix is selected for the Multi-Lane Test Option field.
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Figure 79 Configure Tab Settings

10 In the dialog box, select Enter full SICL address or VISA alias and paste (CTRL-V) the SICL address into 
the field as shown in Figure 80.

11 Click Identify to confirm the connection. 

12 Click OK to close the dialog box.

Figure 80 Entering the Switching Test Set’s Address

13 Refer to the application’s Help system to learn how to configure the switch settings.
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